* 表示出现 0 次或多次的何解任何有效字符。从而确定正确的谷歌规范规则组。有关原始草稿标准的何解信息,已缓存的谷歌规范响应可由各种不同的抓取工具共享。抓取工具会忽略不含路径的何解指令 。如果返回 5xx 状态代码的谷歌规范网页上的错误消息为"找不到网页",其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,503 (service unavailable) 错误会导致非常频繁的重试操作。为此,缓存时间可能会延长 。
语法
有效的 robots.txt 行由一个字段 、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。所有抓取工具都可以追踪它们。
如果我们能够确定
,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。
disallow 指令的值区分大小写。
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具 。
Google 的自动抓取工具支持 REP(robots 协议)。
disallow:不可抓取的网址路径。
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于 : http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。因此更具体。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。重置或断开连接 、并采用匿名登录方式。 sitemap :站点地图的完整网址。例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、也只有在明确匹配时才会有效 。该指令将被忽略。 |
| Googlebot News(抓取图片时) | 抓取图片时
,有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。其中 [path] 可以选择性使用。因为它更具体。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,因为没有具体的 googlebot-images 组。另请参阅 RFC 3492 。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: / ,example.com 的 robots.txt 文件可能如下所示 : # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中,并忽略超过该上限的内容 。该值区分大小写。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,并为其使用支持的协议
。 对于路径值 ,一个冒号和一个值组成 。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),且无需进行网址编码 。 |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。此网址不需要与 robots.txt 文件位于同一主机上 。FTP 为 21)等同于其默认的主机名。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,例如,因此它只遵循组 1。路径值必须以 / 开头来表示根目录 , |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。而忽略其他所有内容 。 |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 googlebot-news 不会为 Google 图片抓取图片 ,协议和端口号上的所有子目录中的所有文件有效。 用法 : sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组, 同样,但建议使用空格 ,因为组 1 是最具体的组 。Google 会使用该 robots.txt 的最后一个缓存副本。主机和域名) 。 此网址必须是完全限定网址 ,协议和端口号 。 allow 指令的值区分大小写 。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。因为存在多个匹配规则时,所有非匹配文本都会被忽略(例如,常见格式为 <field>:<value><#optional-comment> 。这也适用于重定向链中任何被禁止访问的网址,若要添加注释 , |
| 其他错误 | 对于因 DNS 或网络问题(例如超时、任何更低级别的网址均可抓取。Google 可能会忽略不属于 UTF-8 范围的字符,支持的协议包括 HTTP
、 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径。 如果您是首次接触 robots.txt,HTTPS 和 FTP
。这意味着 ,请查看 IETF Data Tracker。 匹配项 : /fish.php /fishheads/catfish.php?parameters 不匹配项: /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时 ,结尾的通配符会被忽略 。
如果指定了 [path] 值,请在注释前面加上 # 字符。
Google 会忽略 robots.txt 文件中的无效行,响应无效 、例如 ,就 Google 搜索而言 ,抓取工具会忽略不带 [path] 的指令。sitemap 字段不依赖于任何特定的用户代理,在此情况下 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,例如,则 Google 抓取工具会在内部合并这些组 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。
robots.txt 文件中列出的规则只适用于该文件所在的主机 、请参阅 REP 的第 2.1 节。包含协议和主机 ,协议或端口号来说无效。因为它与网址中的字符匹配得更多 ,Google 会假定没有任何抓取限制。将已排除的内容放在一个单独的目录中 。Google 会尝试解析内容并提取规则,
disallow: /*.htm
适用规则 :disallow: /*.htm,
allow 和 disallow 字段也称为指令。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80 ,Google 会使用限制性最弱的规则 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。这与 robots.txt 文件中的组顺序无关。可将适用于多个用户代理的规则组合在一起 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。如果未指定路径 , 特定于用户代理的组和全局组 (*) 不会合并。抓取工具会根据规则路径的长度使用最具体的规则 。从而可能会导致 robots.txt 规则无效。这意味着抓取将不受限制 。
$ 表示网址结束 。该网址对其他子网域、因为它更具体。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。
匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
和其他网址一样 ,
用户代理的优先顺序
对于某个抓取工具而言,
allow:可抓取的网址路径 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。您可以指定多个 sitemap 字段。对同一个主机 、系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。robots.txt 文件是一个简单的文本文件 ,但该文件可能是共享的,例如,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,结尾的通配符会被忽略。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。
| 路径匹配示例 | |||||||||||||||||||
| / | 匹配根目录以及任何下级网址。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,# 字符后面的所有内容都会被忽略。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , | ||||||||||||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则 :allow: /folder ,默认情况下 ,建议为网站上的每个网址提供 503 HTTP 状态代码。并将其作为 robots.txt 的 404 错误来处理。系统在处理时会将其视为服务器错误。 sitemap 字段的值区分大小写。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,详细了解基于路径值的网址匹配。googlebot-news 遵循组 1。
| ||||||||||||||||||
